<!DOCTYPE html><html prefix="og: http://ogp.me/ns#" lang="en">
<head>
    <meta charset="utf-8">
    <title>Recall Watch: Harley Recalls Street 500 And 750 For Brakes</title>
            <link href="/design/images/webapp/rideapart/i152.png" sizes="152x152" rel="apple-touch-icon-precomposed"/>
        <link href="/design/images/webapp/rideapart/i144.png" sizes="144x144" rel="apple-touch-icon-precomposed"/>
        <link href="/design/images/webapp/rideapart/i76.png" sizes="76x76" rel="apple-touch-icon-precomposed"/>
        <link href="/design/images/webapp/rideapart/i72.png" sizes="72x72" rel="apple-touch-icon-precomposed"/>
        <link href="/design/images/webapp/rideapart/i180.png" sizes="120x120" rel="apple-touch-icon-precomposed"/>
        <link href="/design/images/webapp/rideapart/i114.png" sizes="114x114" rel="apple-touch-icon-precomposed"/>
        <link href="/design/images/webapp/rideapart/i57.png" sizes="57x57" rel="apple-touch-icon-precomposed"/>
        <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/>

    

        <script>
        window.polymerLocale = 'en-US';
        window.polymerLocalePath = 'https://cdn.motor1.com/static4ui/prod_v2_233/polymer2/locales1547825877/en-US.json';
        var jsVars = {"services":{"brealtime":{"load":0,"id":"12851701"}},"ads":{"dfp":{"id":"6122441"}},"ui":{"auto_infinite_scroll":true}};    </script>

    
    <link title="Latest news" type="application/rss+xml" rel="alternate" href="/rss/news/all/"/>
    <link title="Latest videos" type="application/rss+xml" rel="alternate" href="/rss/videos/all/"/>
    <meta name="description" content="A Harley-Davidson recall has officially been published by Transport Canada for faulty brakes on the Street 500 and 750. Owners should contact the H-D service.">
<meta http-equiv="content-language" content="en">
<meta property="og:title" content="Recall Watch: Harley Recalls Street 500 And 750 For Brakes">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/">
<meta property="og:image" content="https://cdn.motor1.com/images/mgl/krkLx/s4/recall-harley-davidson-street-500.jpg">
<meta property="og:image:width" content="889">
<meta property="og:image:height" content="500">
<meta property="og:description" content="A Harley-Davidson recall has officially been published by Transport Canada for faulty brakes on the Street 500 and 750. Owners should contact the H-D service.">
<meta property="og:site_name" content="RideApart.com">
<meta property="fb:admins" content="100001157785488">
<meta property="fb:app_id" content="264037980905215">
<meta property="fb:pages" content="64968240897">
<meta property="twitter:card" content="summary">
<meta property="twitter:site" content="RideApart.com">
<meta property="twitter:title" content="Recall Watch: Harley Recalls Street 500 And 750 For Brakes">
<meta property="twitter:description" content="A Harley-Davidson recall has officially been published by Transport Canada for faulty brakes on the Street 500 and 750. Owners should contact the H-D service.">
<meta property="twitter:image" content="https://cdn.motor1.com/images/mgl/krkLx/s4/recall-harley-davidson-street-500.jpg">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link href="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" hreflang="x-default" rel="alternate">
<link href="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" hreflang="en" rel="alternate">
<link href="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" rel="canonical">
<link href="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/amp/" rel="amphtml">    <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/css/0_ca3f9e135beb434dad60.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/css/1_ca3f9e135beb434dad60.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/css/3_ca3f9e135beb434dad60.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/css/4_ca3f9e135beb434dad60.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/css/11_ca3f9e135beb434dad60.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/css/18_ca3f9e135beb434dad60.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/css/index_articles_detail_ca3f9e135beb434dad60.css">            <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/static4ui/prod_v2_233/ra-design/dist/css/0_7ec10da347405bb4731e.css">    
    <script>
        window.isAuthorized = 0    </script>


    


    </head>
<body         class="nojs not-touch 
            bgWhite lightHeader hangingHeader newsTitleInTop                                                "
        data-spotim-id="" data-edtn="ra_us"
        data-track-url="" >

<div data-role="page" id="page_index_articles_detail" class="root">

    <div class="m1-header-ad">
    <div class="m1-gapb-topside"><div class="m1-apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:1px;" data-dfp-code="RA/ra_us/Mobile_Leaderboard" data-sizes="320x1,320x50,320x100" data-width="320" data-height="1" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"top-banners","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"top","ra_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:1px;" data-dfp-code="RA/ra_us/Leaderboard" data-sizes="728x1,728x90" data-width="728" data-height="1" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"top-banners","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"top","ra_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb super"><div class="ap" data-place="6" style="width:970px;min-height:1px;" data-dfp-code="RA/ra_us/Super" data-sizes="970x1,970x90,970x250,980x250" data-width="970" data-height="1" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"top-banners","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"top","ra_banner_position_view":"above-the-fold"}'></div></div></div></div><div id="layout_header_spacer"></div>
<div class="m1-header-main">
    <div class="m1-header-main-box">
        <div class="m1-header-main-box-wrapper">
            <div class="box-item-left">
                <div class="m1-hamburger-button" data-hide-scroll="m1-left-side-box" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="toggleBox" data-value="mainMenu" data-clear="2" data-multi>
                    <span></span>
                    <span></span>
                    <span></span>
                </div>

            </div>
            <div class="wrapper-box-item-center">
                <div class="box-item-center">
                    <a class="m1-header-logo" href="/" title="Home"></a>
                </div>
            </div>
            <div class="box-item-pre-left">
                <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/articles/" >
                Articles            </a>
        </li>
                    <li class="grand top mobile">
            <a href="/articles/category/how-to/" >
                How To            </a>
        </li>
                    <li class="grand top">
            <a href="/articles/category/gear/" >
                Gear            </a>
        </li>
                    <li class="grand top">
            <a href="/articles/category/lists/" >
                Lists            </a>
        </li>
                    <li class="grand left">
            <a href="/articles/category/how-to/" >
                How To            </a>
        </li>
                    <li class="grand left">
            <a href="/articles/category/gear/" >
                Gear            </a>
        </li>
                    <li class="grand left">
            <a href="/articles/category/lists/" >
                Lists            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/reviews/" >
                Reviews            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/rideapart-women/" >
                RideApart Women            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/hfl/" >
                HFL            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/racing/" >
                Racing            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/motorcycle-history/" >
                history            </a>
        </li>
                    <li class="left">
            <a href="/articles/?sc=1" >
                all categories            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/" >
                Photos            </a>
        </li>
    </ul>            </div>
            <div class="m1-search-form-button-wrapper search-bar-desktop">
                <button class="m1-search-form-button-animate icon-search" 
                        onclick 
                        data-button 
                        data-id="toggleBox" 
                        data-clear="1"
                        data-value="searchBox"
                        data-multi 
                        type="submite">
                </button>
                <div class="m1-search-panel"> 
                    <form action="/search/" class="m1-search-form" method="GET" id="header_search_form" data-native="0" novalidate="novalidate"> 
                        <input class="m1-search-panel-input m1-search-form-text" type="text" value="" name="q" placeholder="Search" autocomplete="off"> 
                        <button class="m1-search-panel-button m1-search-form-button-animate icon-search " type="submit"> 
                        </button> 
                        <button onclick="" 
                                data-button
                                data-id="toggleBox" 
                                data-value="searchBox" 
                                data-clear="1"
                                data-toggle="1"
                                data-multi 
                                class="m1-search-panel-button m1-drawer-close-button"> 
                        </button> 
                    </form> 
                </div>
            </div>
                    </div>    
    </div>
</div>
    <div class="pageAdSkin" id="page_skin_top">
        <div class="adSizer"><img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw=="></div>
        <a class="pageAdSkinUrl"></a>
    </div>    
<script type="application/ld+json">
    {"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"Recall Watch: Harley Recalls Street 500 And 750 For Brakes","name":"Recall Watch: Harley Recalls Street 500 And 750 For Brakes","description":"First recall of 2019 goes to our Milwaukee friends. ","author":{"@type":"Person","name":"Sabrina Giacomini"},"url":"https:\/\/www.rideapart.com\/articles\/301878\/recall-watch-harley-recalls-street-500-and-750-for-brakes\/","sameAs":["https:\/\/www.facebook.com\/RideApart","https:\/\/twitter.com\/RideApart","https:\/\/pinterest.com\/RideApart","https:\/\/www.instagram.com\/RideApart\/"],"datePublished":"2019-01-21T12:17:23+00:00","dateModified":"2019-01-21T12:17:23+00:00","publisher":{"@type":"Organization","name":"RideApart.com","logo":{"@type":"ImageObject","url":"https:\/\/www.rideapart.com\/logo.jpg","width":"325","height":"60"}},"image":{"@type":"ImageObject","url":"https:\/\/cdn.motor1.com\/images\/mgl\/krkLx\/s1\/recall-harley-davidson-street-500.jpg","width":"1920","height":"1080"},"mainEntityOfPage":"https:\/\/www.rideapart.com\/articles\/301878\/recall-watch-harley-recalls-street-500-and-750-for-brakes\/"}</script>




    <div class="pre-center pre-center-breadcrumbs">
        <div class="g-padding t-padding breadcrumbs-box ntr">
            	<div class="carSpecs small">
		

		<div class="specs-list">
								<a style="background:#000000;color:#ffffff;" href="/articles/category/recalls/" class="item cat-sticker cat-recalls"><span class="name">Recalls</span></a>
						</div>
	</div>
                    <div slot="breadcrumbs" class="breadcrumbs">
        <a href="/">Home</a><span class="sep"></span><a href="/harley-davidson/">Harley-Davidson</a><span class="sep"></span><a href="/harley-davidson/street-500/">Street 500</a><span class="sep"></span><a href="/harley-davidson/street-500/articles/">Articles</a>    </div>
        </div>

        <div class="content-header">
            <div class="articleTitle">
                <h1 class="m1-article-title">Recall Watch: Harley Recalls Street 500 And 750 For Brakes</h1>
            </div>
        </div>
    </div>

    <div class="ready-center padg light">
        <div class="articleHeader">
            <div class="box-center">
                <div class="originalImage">
                    <img src="https://cdn.motor1.com/images/mgl/krkLx/s4/recall-harley-davidson-street-500.jpg" alt="Recall Watch: Harley Recalls Street 500 And 750 For Brakes" />
                </div>
                <div id="article_poster" class="articlePoster scrollTieBox">
                                            <style type="text/css">
@media only screen{#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/krkLx/s4/recall-harley-davidson-street-500.jpg);}}
@media only screen and (min-width : 1024px){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/krkLx/s3/recall-harley-davidson-street-500.jpg);}}
@media only screen and (min-width : 1281px){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/krkLx/s2/recall-harley-davidson-street-500.jpg);}}
@media only screen and (min-width : 1441px){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/krkLx/s1/recall-harley-davidson-street-500.jpg);}}
@media only screen and (-webkit-min-device-pixel-ratio : 2), only screen and (min--moz-device-pixel-ratio : 2), only screen and (min-device-pixel-ratio : 2){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/krkLx/s2/recall-harley-davidson-street-500.jpg);}}
@media only screen and (min-width : 1024px) and (-webkit-min-device-pixel-ratio : 2), only screen and (min-width : 1024px) and (min--moz-device-pixel-ratio : 2), only screen and (min-width : 1024px) and (min-device-pixel-ratio : 2){#article_poster{background-image:url(https://cdn.motor1.com/images/mgl/krkLx/s1/recall-harley-davidson-street-500.jpg);}}
</style>                                        
<img class="sizer" src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAABAAAAAJCAYAAAA7KqwyAAAAGXRFWHRTb2Z0d2FyZQBBZG9iZSBJbWFnZVJlYWR5ccllPAAAABpJREFUeNpi/P//PwMlgImBQjBqwLAwACDAAOVfAw9/ZDvcAAAAAElFTkSuQmCC" alt=""/>                </div>
            </div>
            <div class="articleTitle">
                <div class="box-center">
                    <div class="pre-center">
                                            </div>
                </div>
            </div>
        </div>
    </div>



<div class="pre-center padding h-entry b-padding-skin" id="post_box">
    <div data-bubbles="keyword" data-url="/news/store-keywords/" data-name="id"></div>
    <div class="content-area " id="article_box">
                    <span class="summary p-name" style="display: none;">Recall Watch: Harley Recalls Street 500 And 750 For Brakes</span>


            <span style="display: none;" class="type">product</span>

                    <span style="display: none;" class="dt-published dtreviewed">2019-01-21 12:17:23</span>

                    <a style="display: none" rel="self bookmark" href="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" class="permalink u-url">https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/</a>

                <span class="p-item item vcard" style="display: none;">
            <span class="fn">
                                                            Harley-Davidson Street 500                                            Harley-Davidson Street 750                                                </span>
        </span>

                <span class="p-category" style="display: none;">
                                                                                                                                                                                                                
            Industry, News, Cruisers, Recalls        </span>

        <div class="content-area-box">
                            <div class="postTopInfo">
                    <div class="postDate">
                            <span class="date" data-time="1548058643">
                    <a href="/articles/2019/01/21/">
                Jan 21, 2019            </a>
                <span class="small">at</span> 08:17    </span>
                    </div>

                    <div class="shareTrendingBox">
                                                <div slot="share-box" class="shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><a href="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F&text=Recall+Watch%3A+Harley+Recalls+Street+500+And+750+For+Brakes&via=RideApart"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F&title=Recall+Watch%3A+Harley+Recalls+Street+500+And+750+For+Brakes&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="pinterest"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="4" data-share-network="Pinterest" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="700" data-height="550" href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F&media=https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FkrkLx%2Fs4%2Frecall-harley-davidson-street-500.jpg"><span class="social-bg icon pinterest"></span><span class="name">Pin It</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F&subject=Recall%20Watch%3A%20Harley%20Recalls%20Street%20500%20And%20750%20For%20Brakes"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                    </div>
                                        
<div class="postAuthorBox withAvatar">
		<div class="postAuthorThumb">
		<a class="userRThumb" href="/info/team/sabrina-giacomini/">
			<img src="https://cdn.motor1.com/images/atr/8A1o/s4/sabrina-giacomini.jpg" alt="Sabrina Giacomini" />
		</a>
	</div>
		<div class="postAuthorInfo">
		<div class="postAuthor">
			<span class="name">
				<span class="label">By</span>: 
				<a class="author h-card reviewer p-author vcard url fn" content="Sabrina Giacomini" href="/info/team/sabrina-giacomini/">Sabrina Giacomini</a></span>, <span class="mood">Managing Editor</span>		</div>
				        	</div>
</div>
                    <div class="clear"></div>

                </div>

            <div class="postContent content-wrapper" itemprop="description">
                
                                    <h2 class="preview">
                        First recall of 2019 goes to our Milwaukee friends.                     </h2>
                
                                                        <div class="apInarticleSmallRes"><div class="ap" data-place="16" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/Mobile_Rectangle" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"inarticle-small-res","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"inarticle-small-res"}'></div></div>                                <div class="postBody description e-content">
                                <p><span style="font-weight: 400;">In August of 2018, Harley-Davidson emitted a massive, <a href="https://www.rideapart.com/articles/244947/harley-davidson-recalls-250000-bikes-for-faulty-brakes/" target="_self">global-wide recall</a> for faulty brakes on close to a quarter-of-a-million units of some of its bigger cruisers. The company is now serving us our first official <a href="https://www.rideapart.com/articles/category/recalls/" target="_self">recall</a> of 2019 for brake problems once more. This time, recent versions of the Streets are concerned. </span></p>
<section class="relatedContent-new " contenteditable="false" draggable="true" data-widget="related-content" data-widget-size="content" data-params="%7B%22type_id%22%3A0%2C%22title_id%22%3A%22%22%2C%22items%22%3A%5B%7B%22article_edition_id%22%3A%22281235%22%2C%22title%22%3A%222018%20Recall%20Roundup%3A%20Bikes%20That%20Need%20A%20Little%20Extra%20Love%20%5BUPDATE%5D%22%2C%22alias%22%3A%222018-recall-roundup-bikes-love%22%2C%22section%22%3A%224%22%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FWk2PO%2Fs5%2Fsuzuki-sport-bikes.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22297525%22%2C%22title%22%3A%22Recall%3A%20The%20Kawasaki%202018%20Z900%20May%20Leak%20Brake%20Fluid%22%2C%22alias%22%3A%22recall-kawasaki-2018-z900-1%22%2C%22section%22%3A%224%22%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FZRBXy%2Fs5%2Fup-close-and-personal-with-the-kawasaki-z900rs.jpg%22%7D%7D%5D%7D">
<h2 class="trending-content_header">HARLEY ISN'T ALONE</h2>
<div class="wrapper-related-item">
<div class="related-item"><a href="/articles/281235/2018-recall-roundup-bikes-love/"> <span class="related-item-img"> <img src="https://cdn.motor1.com/images/mgl/Wk2PO/s5/suzuki-sport-bikes.jpg" /> </span> <span class="title-related-item">2018 Recall Roundup: Bikes That Need A Little Extra Love [UPDATE]</span> </a></div>
<div class="related-item"><a href="/articles/297525/recall-kawasaki-2018-z900-1/"> <span class="related-item-img"> <img src="https://cdn.motor1.com/images/mgl/ZRBXy/s5/up-close-and-personal-with-the-kawasaki-z900rs.jpg" /> </span> <span class="title-related-item">Recall: The Kawasaki 2018 Z900 May Leak Brake Fluid</span> </a></div>
</div>
</section>
<p><span style="font-weight: 400;">Once again, our neighbors north of the border have pulled the trigger faster than the NHTSA has and posted a Harley-Davidson recall on 2016 through 2019 Street 500 and 750 for potentially faulty brakes. While 850 units could present the issue in Canada, the NHTSA has yet to confirm the numbers in the United States. </span></p><div class="item m1-ap-native"><div class="ap" data-place="22"  data-dfp-code="RA/ra_us/Native" data-sizes="fluid,1x1" data-width="1" data-height="1" data-dfp-attrs='{"m1_native":"1","msnt_env":"production","ra_banner_place":"native","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"native"}'></div></div>
<p><span style="font-weight: 400;">The company has found out that on certain 2016, 2017, 2018, and 2019 units of both the Streets 500 and 750, the brake pads could be dragging on the wheel due to the corrosion of the calliper piston. Dragging brakes could mean premature wear of the pads and/or to the disc. In a worst-case-scenario type of situation, should the user pull the brake completely, the piston could fail to retract and maintain the brake pad applied to the disc, keeping it from moving forward. The company mentions that the problem is most likely to occurs to owners living in areas that create a rust-prone environment for the motorcycle, including coastal sectors. Winters riders, this could also be you! </span></p>
<p><span style="font-weight: 400;">While an official recall number has yet to be released by the NHTSA, owners of recent-years Streets can give the Harley-Davidson customer service a call at 1-800-258-2464 with their Vehicle Identification Number (VIN) in hand to verify whether their unit is affected. Owners of the units involved in the recall will be invited to visit their H-D dealer where they will receive a new set of front and rear brake callipers free of charge.</span></p>
<p><em><span style="font-weight: 400;">Source: <a href="http://wwwapps.tc.gc.ca/Saf-Sec-Sur/7/VRDB-BDRV/search-recherche/detail.aspx?lang=eng&amp;mk=31158!2064&amp;md=STREET%20500&amp;fy=0&amp;ty=9999&amp;ft=&amp;ls=0&amp;sy=0&amp;rn=2018734&amp;cf=SearchResult&amp;pg=0" target="_self">Transport Canada</a></span></em></p><div class="item m1-ap-native"><div class="ap" data-place="22"  data-dfp-code="RA/ra_us/Native" data-sizes="fluid,1x1" data-width="1" data-height="1" data-dfp-attrs='{"m1_native":"2","msnt_env":"production","ra_banner_place":"native","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"native"}'></div></div>                </div>
                                                
                                
                                
                                
                            </div>
        </div>
        <div class="sidebar" id="post_sidebar">
                            <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"dmpu_first","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"sidebar"}'></div></div>                                
                            <div class="trending-content">
                    <div class="content-header">
                        <h2 class="trending-content_header">Trending</h2>
                    </div>
                                            <div class="trending-content_item">
                            <a class="trending-content_thumb thumb zoom" href="/articles/301749/campagna-trex-shut-down/">
                                                                    <img class="lazy" src="https://cdn.motor1.com/images/mgl/Bb9vZ/s6/update-jurassic-spark-2-pictures-have-arrived.jpg" alt="Campagna T-Rex Defeated By Hungry Bankers"/>
                            </a>
                            <a class="trending-content_link" href="/articles/301749/campagna-trex-shut-down/">Campagna T-Rex Defeated By Hungry Bankers</a>
                        </div>
                                            <div class="trending-content_item">
                            <a class="trending-content_thumb thumb zoom" href="/articles/301685/electric-motorcycle-ducati-coming-soon/">
                                                                    <img class="lazy" src="https://cdn.motor1.com/images/mgl/geP0o/s6/electric-ducati-in-the-works.jpg" alt="Ducati Could Go Electric Much Sooner Than We Expect It"/>
                            </a>
                            <a class="trending-content_link" href="/articles/301685/electric-motorcycle-ducati-coming-soon/">Ducati Could Go Electric Much Sooner Than We Expect It</a>
                        </div>
                                            <div class="trending-content_item">
                            <a class="trending-content_thumb thumb zoom" href="/articles/301639/toby-price-ktm-2019-dakar/">
                                                                    <img class="lazy" src="https://cdn.motor1.com/images/mgl/pveEP/s6/dakar-2019-results.jpg" alt="Toby Price From KTM Crew Wins 2019 Dakar"/>
                            </a>
                            <a class="trending-content_link" href="/articles/301639/toby-price-ktm-2019-dakar/">Toby Price From KTM Crew Wins 2019 Dakar</a>
                        </div>
                                            <div class="trending-content_item">
                            <a class="trending-content_thumb thumb zoom" href="/articles/300408/how-not-to-tow-motorcycle/">
                                                                    <img class="lazy" src="https://cdn.motor1.com/images/mgl/6WenZ/s6/how-not-to-tow-a-motorcycle.jpg" alt="This Is How Not To Tow A Motorcycle"/>
                            </a>
                            <a class="trending-content_link" href="/articles/300408/how-not-to-tow-motorcycle/">This Is How Not To Tow A Motorcycle</a>
                        </div>
                                    </div>
                                                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"dmpu","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"sidebar"}'></div></div>                    </div>
        <div class="clear"></div>
    </div>
</div>

        

    <div id="container_3rd_party_service" class="container_3rd_party pre-center padding print-hide" data-edtn="ra_us">

        <div class="content-area">
            <div class="content-area-box">
                                    <div class="trending-content b-m-padding b-padding trending-content_mobile">
                        <div class="content-header">
                            <h2 class="trending-content_header">Trending</h2>
                        </div>
                                                            <div class="trending-content_item trending-content_item-mobile">
                                    <a class="trending-content_thumb thumb zoom" href="/articles/301749/campagna-trex-shut-down/">
                                                                                <img class="lazy" src="https://cdn.motor1.com/images/mgl/Bb9vZ/s6/update-jurassic-spark-2-pictures-have-arrived.jpg" alt="Campagna T-Rex Defeated By Hungry Bankers"/>
                                    </a>
                                    <a class="trending-content_link" href="/articles/301749/campagna-trex-shut-down/">Campagna T-Rex Defeated By Hungry Bankers</a>
                                </div>
                                                            <div class="trending-content_item trending-content_item-mobile">
                                    <a class="trending-content_thumb thumb zoom" href="/articles/301685/electric-motorcycle-ducati-coming-soon/">
                                                                                <img class="lazy" src="https://cdn.motor1.com/images/mgl/geP0o/s6/electric-ducati-in-the-works.jpg" alt="Ducati Could Go Electric Much Sooner Than We Expect It"/>
                                    </a>
                                    <a class="trending-content_link" href="/articles/301685/electric-motorcycle-ducati-coming-soon/">Ducati Could Go Electric Much Sooner Than We Expect It</a>
                                </div>
                                                            <div class="trending-content_item trending-content_item-mobile">
                                    <a class="trending-content_thumb thumb zoom" href="/articles/301639/toby-price-ktm-2019-dakar/">
                                                                                <img class="lazy" src="https://cdn.motor1.com/images/mgl/pveEP/s6/dakar-2019-results.jpg" alt="Toby Price From KTM Crew Wins 2019 Dakar"/>
                                    </a>
                                    <a class="trending-content_link" href="/articles/301639/toby-price-ktm-2019-dakar/">Toby Price From KTM Crew Wins 2019 Dakar</a>
                                </div>
                                                            <div class="trending-content_item trending-content_item-mobile">
                                    <a class="trending-content_thumb thumb zoom" href="/articles/300408/how-not-to-tow-motorcycle/">
                                                                                <img class="lazy" src="https://cdn.motor1.com/images/mgl/6WenZ/s6/how-not-to-tow-a-motorcycle.jpg" alt="This Is How Not To Tow A Motorcycle"/>
                                    </a>
                                    <a class="trending-content_link" href="/articles/300408/how-not-to-tow-motorcycle/">This Is How Not To Tow A Motorcycle</a>
                                </div>
                                                </div>
                                                                            <div class="comment-container no-apb">
                                                                                                <div id="disqus_thread" class="diquas-wrapper" data-cid="article-301878" data-url="/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/">
                                    </div>
                                                                                    </div>
                                                </div>
            <div class="sidebar">
                <div class="mobile-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"dmpu","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"sidebar"}'></div></div>                </div>
                <div class="lazy-load-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"dmpu","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"sidebar"}'></div></div>                </div>
            </div>
            <div class="clear"></div>
        </div>


                
        
                    <div class="zergnet-wrapper" 
                data-paidIdAbove="64179" 
                data-paidIdBelow="">
            </div>
        
        
        
                                </div>
    
<div class="pre-center mobile-skyscraper-box">
    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"dmpu","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"sidebar"}'></div></div></div>

<div class="cpre-center print-hide">
    </div>


    <div class="pre-center padding print-hide">
        <div class="content-area">
            <div class="content-area-box">
                <h2 class="text-uppercase">About this article</h2>
                <table class="additionalInfo">
                                            <tr>
                            <td>Category</td>
                            <td><div class="list">
                                                                            <a href="/articles/category/industry/">Industry</a>
                                                                            <a href="/articles/category/news/">News</a>
                                                                            <a href="/articles/category/cruisers/">Cruisers</a>
                                                                            <a href="/articles/category/recalls/">Recalls</a>
                                                                    </div></td>
                        </tr>
                                                                                                        <tr>
                            <td>Make</td>
                            <td><div class="list">
                                                                            <a href="/harley-davidson/">Harley-Davidson</a>
                                                                    </div></td>
                        </tr>
                                                                <tr>
                            <td>Model</td>
                            <td><div class="list">
                                                                            <a href="/harley-davidson/street-500/">Street 500</a>
                                                                            <a href="/harley-davidson/street-750/">Street 750</a>
                                                                    </div></td>
                        </tr>
                                    </table>
            </div>
            <div class="sidebar">

            </div>
            <div class="clear"></div>
        </div>
    </div>
    <div id="stop_share_box" class="print-hide"></div>



<div  id="ap_popup_gallery_top"><div class="apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:50px;" data-dfp-code="RA/ra_us/Mobile_Leaderboard" data-sizes="320x50,320x100" data-width="320" data-height="50" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"popup_gallery_top","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"popup_gallery_top"}'></div></div><div class="apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:90px;" data-dfp-code="RA/ra_us/Leaderboard" data-width="728" data-height="90" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"popup_gallery_top","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"popup_gallery_top"}'></div></div><div class="apb super"><div class="ap" data-place="12" style="width:970px;min-height:90px;" data-dfp-code="RA/ra_us/Super" data-width="970" data-height="90" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"popup_gallery_top","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"popup_gallery_top"}'></div></div></div><div id="ap_popup_gallery_rectangle"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"popup_gallery_rectangle","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"popup_gallery_rectangle"}'></div></div>    
</div>
<div class="m1-left-side">
    <div class="m1-drawer search-bar-desktop left-to-right disabled" data-button-target="mainMenu">
        <div onclick="" data-button data-id="toggleBox" data-close-delay="0.5" data-value="mainMenu" data-hide-scroll="m1-left-side-box" data-clear="2" class="m1-drawer-close-button dark active" data-toggle="1" data-multi></div>
        <div class="m1-left-side-top">
            <div class="m1-user-side-label">
                            <span class="label">
                    <a class="login" href="/login/" onclick="" data-button data-id="goToUrl">Sign In</a> 
                    or                        <a class="register" href="/register/" onclick="" data-button data-id="goToUrl">Sign Up</a>
                </span>
                <span class="userpic icon-user"></span>
                        </div>
            <form class="m1-search-form" action="/search/" method="GET">
                <input class="m1-search-form-text" type="search" name="q" value="" placeholder="I'm looking for..." autocomplete="off" />
                <button class="m1-search-form-button icon-search" type="submite"></button>
            </form>
        </div>
        <div class="m1-left-side-box">
            
            <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/articles/" >
                Articles            </a>
        </li>
                    <li class="grand top mobile">
            <a href="/articles/category/how-to/" >
                How To            </a>
        </li>
                    <li class="grand top">
            <a href="/articles/category/gear/" >
                Gear            </a>
        </li>
                    <li class="grand top">
            <a href="/articles/category/lists/" >
                Lists            </a>
        </li>
                    <li class="grand left">
            <a href="/articles/category/how-to/" >
                How To            </a>
        </li>
                    <li class="grand left">
            <a href="/articles/category/gear/" >
                Gear            </a>
        </li>
                    <li class="grand left">
            <a href="/articles/category/lists/" >
                Lists            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/reviews/" >
                Reviews            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/rideapart-women/" >
                RideApart Women            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/hfl/" >
                HFL            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/racing/" >
                Racing            </a>
        </li>
                    <li class="left">
            <a href="/articles/category/motorcycle-history/" >
                history            </a>
        </li>
                    <li class="left">
            <a href="/articles/?sc=1" >
                all categories            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/" >
                Photos            </a>
        </li>
    </ul>            <div class="m1-menus-box">
                <div class="m1-extra-menus-box">
                    <a href="/" class="m1-side-logo"></a>
                                                                <ul class="m1-social-menu">
                                                                                <li><a title="Facebook" class="icon-facebook" href="https://www.facebook.com/RideApart" target="_blank"></a></li>
                                                                                                            <li><a title="Twitter" class="icon-twitter" href="https://twitter.com/RideApart" target="_blank"></a></li>
                                                                                                                                                                                                                                                                                                                                                                                                                                                                                        <li><a title="Instagram" class="icon-instagram" href="https://www.instagram.com/RideApart/" target="_blank"></a></li>
                                                                                                                                                                <li><a title="RSS" class="icon-rss" href="/rss/" ></a></li>
                                                                            </ul>
                                        <ul class="m1-info-menu">
                        <li><a href="/info/about-us/">About Us</a></li>
                        <li>
                                                            <a href="https://mailchi.mp/38770e8be2fc/rideapart-newsletter-signup?utm_source=burger-menu&utm_medium=landing-page&utm_campaign=ride-apart-newsletter-sign-up" target="_blank">
                                    Newsletter                                </a>
                                                    </li>
                        <li><a href="/info/contact/">Contact</a></li>
                        <li><a href="/info/feedback/tip-us/">Tip us</a></li>
                        <li><a href="/info/privacy-policy/">Privacy policy</a></li>
                        <li><a href="/info/cookie-policy/">Cookie policy</a></li>
                    </ul>

                </div>
                <div class="m1-msn-menus-box">
                    <ul class="m1-msn-menu">
                                                    <li class="motorsport"><a href="https://www.motorsport.com/" target="_blank">www.motorsport.com</a></li>
                                                                                                                            <li class="insideevs"><a href="https://insideevs.com/" target="_blank">www.insideevs.com</a></li>
                                                
                        
                                                    <li class="motor1"><a href="https://www.motor1.com/" target="_blank">www.motor1.com</a></li>
                        
                                                    <li class="ferrarichat"><a href="https://www.ferrarichat.com" target="_blank">www.ferrarichat.com</a></li>
                        
                                                
                    </ul>
                </div>  
                <div class="m1-footer">
                    &copy; 2019 <a target="_blank" class="m1-msn-name" href="https://www.motorsportnetwork.com/company/about">Motorsport Network.</a>                                     </div>
            </div>
        </div>
    </div>
    <div class="m1-drawer-overlay"></div>
</div>

<m1-check-availability-response-dialog
        user-data='{"email":"","zip":"20149","phone":"","firstName":"","lastName":""}'
        edition="ra_us"
        oem-url="/buy/new/lead/"
        vin-url="/buy/used/lead/"
></m1-check-availability-response-dialog>


    <div id="share_box_content_wrapper">
        <div slot="share-box" class="shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><a href="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" class="share-button"><span class="name">Share</span><span class="icon share-empty"></span></a><div class="share-list"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F&text=Recall+Watch%3A+Harley+Recalls+Street+500+And+750+For+Brakes&via=RideApart"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F&title=Recall+Watch%3A+Harley+Recalls+Street+500+And+750+For+Brakes&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="pinterest"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="4" data-share-network="Pinterest" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="700" data-height="550" href="https://www.pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F&media=https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FkrkLx%2Fs4%2Frecall-harley-davidson-street-500.jpg"><span class="social-bg icon pinterest"></span><span class="name">Pin It</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'301878',type_id:'1'" data-share-url="https://www.rideapart.com/articles/301878/recall-watch-harley-recalls-street-500-and-750-for-brakes/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Fwww.rideapart.com%2Farticles%2F301878%2Frecall-watch-harley-recalls-street-500-and-750-for-brakes%2F&subject=Recall%20Watch%3A%20Harley%20Recalls%20Street%20500%20And%20750%20For%20Brakes"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>    </div>


<div class="hiddenBlock">
    <div class="apOutstream"><div class="ap" data-place="8" style="width:1px;min-height:1px;" data-dfp-code="RA/ra_us/Outstream" data-width="1" data-height="1" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"outstream","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"outstream"}'></div></div></div>
<div class="apOverlay m1-ap-overlay"><div class="ap" data-place="17" style="width:0px;min-height:0px;" data-dfp-code="RA/ra_us/Overlay" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"overlay","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"overlay"}'></div></div><div class="apOverlay m1-ap-overlay-2"><div class="ap" data-place="18" style="width:0px;min-height:0px;" data-dfp-code="RA/ra_us/Overlay2" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"overlay2","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"overlay2"}'></div></div><div class="apOverlay m1-ap-overlay-3"><div class="ap" data-place="20" style="width:0px;min-height:0px;" data-dfp-code="RA/ra_us/Overlay3" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"overlay3","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"overlay3"}'></div></div><div class="apOverlay m1-ap-overlay-4"><div class="ap" data-place="21" style="width:0px;min-height:0px;" data-dfp-code="RA/ra_us/Overlay4" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","ra_banner_place":"overlay4","ra_edition":"ra_us","ra_page_content_id":301878,"ra_page_type":"detail","ra_page_content_type":"article","ra_makes":["harley-davidson"],"ra_models":["street-500","street-750"],"ra_categories":["industry","news","cruisers","recalls"],"ra_body_types":[null,null],"ra_model_segments":[null],"ra_banner_position":"overlay4"}'></div></div><div class="m1-footer-messages"></div>

                            <script src="//js-sec.indexww.com/ht/p/187923-107093927834093.js" async></script>
                        



        <script type="text/javascript" src="//www.googletagservices.com/tag/js/gpt.js" async></script>

    
<script>
    var m1FooterMessages = [];
    m1FooterMessages.push({
        message: "This website uses cookies to ensure you get the best experience on our website. By closing this banner, scrolling this page you consent to the use of cookies. <a id='cookie_accept_link' data-id='footerMessageAccept' data-button='' href='/info/cookie-policy/'>More info.</a>",
        name: "cookie_accept"
    });
    </script>

<script defer type="text/javascript" src="https://cdn.motor1.com/static4ui/prod_v2_233/design/build/jslangs/rideapart_en_US_90b1785de5d9d4d318b64a471cb4dd07.js"></script>
<script defer type="text/javascript" src="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/js/0_90d52aefc9363176e011.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/js/2_90d52aefc9363176e011.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/static4ui/prod_v2_233/design/dist/js/11_90d52aefc9363176e011.js"></script>


    
<script>
gtmDataLayer = [{
    'currentEdition': 'ra_us',
    'currentEnv': 'production',
        'pageType': 'detail',
            'entityType': 'article',
            'pageId': 'index_articles_detail',
    }];
</script>

<!-- Google Tag Manager  -->
<script>
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer', 'GTM-TCCR6TV');
</script>
<!-- End Google Tag Manager -->



</body>
</html>