<!DOCTYPE html><html prefix="og: http://ogp.me/ns#" lang="en">
<head>
    <meta charset="utf-8">
    <title>EeVe Soul Electric Scooter Expected To Debut Soon</title>

            <link href="https://fonts.googleapis.com/css?family=Open+Sans:300,400,600,700" rel="stylesheet">
    
    <style>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</style>

    <link rel="icon" type="image/png" sizes="32x32" href="https://cdn.motor1.com/images/static/rideapart/favicon-32.png">
    <link rel="icon" type="image/png" sizes="96x96" href="https://cdn.motor1.com/images/static/rideapart/favicon-96.png">
    <link rel="icon" type="image/png" sizes="128x128" href="https://cdn.motor1.com/images/static/rideapart/favicon-128.png">
    <link rel="icon" type="image/png" sizes="195x195" href="https://cdn.motor1.com/images/static/rideapart/favicon-195.png">
    <link rel="icon" type="image/png" sizes="196x196" href="https://cdn.motor1.com/images/static/rideapart/favicon-196.png">
    <link rel="icon" type="image/png" sizes="228x228" href="https://cdn.motor1.com/images/static/rideapart/favicon-228.png">
    <link rel="apple-touch-icon-precomposed" href="https://cdn.motor1.com/images/static/rideapart/favicon-57.png">
    <link rel="apple-touch-icon" sizes="114x114" href="https://cdn.motor1.com/images/static/rideapart/favicon-114.png">
    <link rel="apple-touch-icon" sizes="72x72" href="https://cdn.motor1.com/images/static/rideapart/favicon-72.png">
    <link rel="apple-touch-icon" sizes="144x144" href="https://cdn.motor1.com/images/static/rideapart/favicon-144.png">
    <link rel="apple-touch-icon" sizes="60x60" href="https://cdn.motor1.com/images/static/rideapart/favicon-60.png">
    <link rel="apple-touch-icon" sizes="120x120" href="https://cdn.motor1.com/images/static/rideapart/favicon-120.png">
    <link rel="apple-touch-icon" sizes="76x76" href="https://cdn.motor1.com/images/static/rideapart/favicon-76.png">
    <link rel="apple-touch-icon" sizes="152x152" href="https://cdn.motor1.com/images/static/rideapart/favicon-152.png">
    <link rel="apple-touch-icon" sizes="180x180" href="https://cdn.motor1.com/images/static/rideapart/favicon-180.png">

    <meta name="msapplication-square128x128logo" content="https://cdn.motor1.com/images/static/rideapart/smalltile.png"/>
    <meta name="msapplication-square270x270logo" content="https://cdn.motor1.com/images/static/rideapart/mediumtile.png"/>
    <meta name="msapplication-square580x580logo" content="https://cdn.motor1.com/images/static/rideapart/largetile.png"/>

    
    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico"/>
    

    

        <script>
        window.polymerLocale = 'en-US';
        window.polymerLocalePath = 'https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/polymer2/locales1619517753/en-US.json';
        var jsVars = {"services":{"brealtime":{"load":0,"id":"12851701"}},"ads":{"dfp":{"id":"6122441"}},"ui":{"auto_infinite_scroll":true}};    </script>

    
    <link title="Latest news" type="application/rss+xml" rel="alternate" href="/rss/news/all/"/>
    <link title="Latest videos" type="application/rss+xml" rel="alternate" href="/rss/videos/all/"/>
        <meta name="description" content="Indian electric two-wheeler startup Eeve is expected to launch the Soul, its newest addition to its fleet of lightweight electric scooters. ">
<meta property="og:title" content="EeVe Soul Electric Scooter Expected To Debut Soon">
<meta property="og:type" content="article">
<meta property="og:url" content="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/">
<meta property="og:image" content="https://cdn.motor1.com/images/mgl/XxEq9/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg">
<meta property="og:image:url" content="https://cdn.motor1.com/images/mgl/XxEq9/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg">
<meta property="og:image:secure_url" content="https://cdn.motor1.com/images/mgl/XxEq9/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg">
<meta property="og:image:type" content="image/jpeg">
<meta property="og:image:width" content="1920">
<meta property="og:image:height" content="1080">
<meta property="og:image:alt" content="EeVe Soul Electric Scooter Expected To Debut Soon: Electric Motorcycles">
<meta property="og:description" content="Indian electric two-wheeler startup Eeve is expected to launch the Soul, its newest addition to its fleet of lightweight electric scooters. ">
<meta property="og:site_name" content="RideApart.com">
<meta property="fb:admins" content="100001157785488">
<meta property="fb:app_id" content="264037980905215">
<meta property="fb:pages" content="290839527600684">
<meta property="twitter:card" content="summary_large_image">
<meta property="twitter:site" content="RideApart.com">
<meta property="twitter:title" content="EeVe Soul Electric Scooter Expected To Debut Soon">
<meta property="twitter:description" content="Another addition to the list of lightweight electric runabouts. ">
<meta property="twitter:image" content="https://cdn.motor1.com/images/mgl/XxEq9/s3/eeve-soul-electric-scooter-expected-to-debut-soon.jpg">
<meta property="robots" content="max-snippet:500, max-image-preview:large">
<meta name="speakable-description" content="Indian electric two-wheeler startup Eeve is expected to launch the Soul, its newest addition to its fleet of lightweight electric scooters. ">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta http-equiv="X-UA-Compatible" content="IE=edge"><link href="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" hreflang="en" rel="alternate">
<link href="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" hreflang="x-default" rel="alternate">
<link href="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" rel="canonical">
<link href="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/amp/" rel="amphtml">
    <script>
        let bundleRange = `                    <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/css/0_b703516506c01ba1f675.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/css/2_b703516506c01ba1f675.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/css/3_b703516506c01ba1f675.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/css/12_b703516506c01ba1f675.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/css/21_b703516506c01ba1f675.css"><link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/css/index_articles_detail_b703516506c01ba1f675.css">                
                                    <link rel="stylesheet" type="text/css" href="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/ra-design/dist/css/0_2c223ecb302c376f5956.css">                `;

        document.addEventListener('DOMContentLoaded', (event) => {
            $('head').append(bundleRange);
        });
    </script>
    

    <script>
        window.isAuthorized = 0    </script>


    

        
                <script>
                window.top.adGrid = window.top.adGrid || {};
                window.top.adGrid.cmd = window.top.adGrid.cmd || [];
                var adGridInitiate = function() {
                    this.adGridCall(function () {
                        var pageMeta = {};
                        this.setMetaDataFromPage(pageMeta);
                    })
                };
                window.top.adGrid.cmd.push([adGridInitiate]);
        </script>
    
</head>
<body         class="nojs not-touch m1-skin-layout
            bgWhite lightHeader hangingHeader                                                                                    "
        data-spotim-id="" data-edtn="ra_us"
        data-track-url=""         data-rtl="false"

        >
<div class="hiddenBlock">
    <div class="apOutstream"><div class="ap" data-place="8" style="width:1px;min-height:1px;" data-dfp-code="RA/ra_us/Outstream" data-width="1" data-height="1" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"outstream","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"outstream"}'></div></div></div>
<div class="apOverlay m1-ap-overlay"><div class="ap" data-place="17" style="width:0px;min-height:0px;" data-dfp-code="RA/ra_us/Overlay" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"overlay"}'></div></div><div class="apOverlay m1-ap-overlay-2"><div class="ap" data-place="18" style="width:0px;min-height:0px;" data-dfp-code="RA/ra_us/Overlay2" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay2","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"overlay2"}'></div></div><div class="apOverlay m1-ap-overlay-3"><div class="ap" data-place="20" style="width:0px;min-height:0px;" data-dfp-code="RA/ra_us/Overlay3" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay3","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"overlay3"}'></div></div><div class="apOverlay m1-ap-overlay-4"><div class="ap" data-place="21" style="width:0px;min-height:0px;" data-dfp-code="RA/ra_us/Overlay4" data-width="0" data-height="0" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"overlay4","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"overlay4"}'></div></div><div data-role="page" id="page_index_articles_detail" class="root">

    <div id="layout_header_spacer"></div>


<div class="m1-header-main">
            <div class="m1-header-main-box">
        <div class="m1-header-main-box-wrapper">
            <div class="box-item-left">
                <div class="m1-hamburger-button" data-hide-scroll="m1-left-side-box" data-close-delay="0.5" data-delay="0.01" onclick="" data-button data-id="mainMenuToggle" data-value="mainMenu" data-clear="2" data-multi>
                    <span></span>
                    <span></span>
                    <span></span>
                </div>
            </div>
            <div class="wrapper-box-item-center">
                <div class="box-item-center">
                    <a class="m1-header-logo" href="/" title="Home">
                        <img class="logo_placeholder" 
                            src="data:image/png;base64,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"
                            alt="RideApart Logo"
                        >
                    </a>
                </div>
            </div>
            <div class="box-item-center-wrapper-align">
                <ul class="m1-navigation-main print-hide">
                        <li class="grand top left mobile">
            <a href="/news/" >
                                    News                            </a>
        </li>
                    <li class="grand top left mobile">
            <a href="/reviews/" >
                                    Reviews                            </a>
        </li>
                    <li class="grand top left mobile">
            <a href="/features/" >
                                    Features                            </a>
        </li>
                    <li class="top">
            <a href="/motorcycle-lists/" >
                                    Lists                            </a>
        </li>
                    <li class="grand left">
            <a href="/motorcycle-lists/" >
                                    Motorcycle Lists                            </a>
        </li>
                    <li class="left">
            <a href="/features/category/how-to/" >
                                    How To                            </a>
        </li>
                    <li class="left">
            <a href="/reviews/category/gear/" >
                                    Gear                            </a>
        </li>
                    <li class="left">
            <a href="/news/category/rideapart-women/" >
                                    RideApart Women                            </a>
        </li>
                    <li class="left">
            <a href="/news/category/racing/" >
                                    Racing                            </a>
        </li>
                    <li class="left">
            <a href="/features/category/motorcycle-history/" >
                                    history                            </a>
        </li>
                    <li class="left">
            <a href="/makes/" >
                                    makes &amp; models                            </a>
        </li>
                    <li class="photos ico left">
            <a href="/photos/" >
                                    Photos                            </a>
        </li>
                    <li class="videos ico left">
            <a href="/videos/" >
                                    Videos                            </a>
        </li>
    </ul>
                <div class="m1-navigation-main-part-right">
                    <div class="rewards-container">

                    </div>
                                            <div class="m1-search-form-button-wrapper">
                            <button class="m1-search-form-button-animate icon-search m1-mobile-search"
                                    onclick
                                    data-button
                                    data-id="toggleBox"
                                    data-clear="1"
                                    data-value="searchBox"
                                    data-multi
                                    type="submit">
                            </button>
                            <div class="m1-search-panel">
                                <form action="/search/" class="m1-search-form" method="GET" id="header_search_form" data-native="0" novalidate="novalidate">
                                    <input class="m1-search-panel-input m1-search-form-text" id="search_input" type="text" value="" name="q" placeholder="Search" autocomplete="off">
                                    <button class="m1-search-panel-button m1-search-form-button-animate icon-search " type="submit">
                                    </button>
                                    <button onclick=""
                                            data-button
                                            data-id="toggleBox"
                                            data-value="searchBox"
                                            data-clear="1"
                                            data-toggle="1"
                                            data-multi
                                            class="m1-search-panel-button m1-drawer-close-button">
                                    </button>
                                </form>
                            </div>
                        </div>
                                    </div>

                
                
            </div>
                    </div>
    </div>
</div>
<div class="m1-header-ad top-banner-placeholder">
    <div class="m1-gapb-topside"><div class="m1-apb mleaderboard"><div class="ap" data-place="10" style="width:320px;min-height:100px;" data-dfp-code="RA/ra_us/Mobile_Leaderboard" data-sizes="320x100,320x50,320x1" data-width="320" data-height="100" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb leaderboard"><div class="ap" data-place="1" style="width:728px;min-height:90px;" data-dfp-code="RA/ra_us/Leaderboard" data-sizes="728x90,728x1,1x1" data-width="728" data-height="90" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div><div class="m1-apb super"><div class="ap" data-place="6" style="width:970px;min-height:90px;" data-dfp-code="RA/ra_us/Super" data-sizes="970x90,970x250,980x250,970x1,1x1" data-width="970" data-height="90" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"top-banners","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"top","m1_banner_position_view":"above-the-fold"}'></div></div></div></div>    <div class="pageAdSkin" id="page_skin_top">
        <div class="adSizer"><img alt="" src="data:image/gif;base64,R0lGODlhAQABAIAAAP///wAAACH5BAEAAAAALAAAAAABAAEAAAICRAEAOw=="></div>
        <a class="pageAdSkinUrl"></a>
    </div>
    
<script type="application/ld+json">
    {"@context":"http:\/\/schema.org","@type":"NewsArticle","headline":"EeVe Soul Electric Scooter Expected To Debut Soon","description":"Indian electric two-wheeler startup Eeve is expected to launch the Soul, its newest addition to its fleet of lightweight electric scooters. ","author":{"@type":"Person","name":"Enrico Punsalang"},"url":"https:\/\/www.rideapart.com\/news\/505612\/eeve-soul-electric-scooter-coming-soon\/","datePublished":"2021-05-06T05:47:12Z","dateModified":"2021-05-06T05:48:01Z","publisher":{"@type":"Organization","name":"RideApart.com","logo":{"@type":"ImageObject","url":"https:\/\/www.rideapart.com\/logo.jpg","width":"273","height":"60"}},"image":["https:\/\/cdn.motor1.com\/images\/mgl\/XxEq9\/s1\/eeve-soul-electric-scooter-expected-to-debut-soon.webp","https:\/\/cdn.motor1.com\/images\/mgl\/XxEq9\/s1\/4x3\/eeve-soul-electric-scooter-expected-to-debut-soon.webp","https:\/\/cdn.motor1.com\/images\/mgl\/XxEq9\/s1\/1x1\/eeve-soul-electric-scooter-expected-to-debut-soon.webp"],"mainEntityOfPage":{"@type":"WebPage","url":"https:\/\/www.rideapart.com\/news\/505612\/eeve-soul-electric-scooter-coming-soon\/"},"wordCount":"391"}</script>



    <script type="application/ld+json">
        {"@context":"https:\/\/schema.org\/","@type":"WebPage","name":"EeVe Soul Electric Scooter Expected To Debut Soon","speakable":{"@type":"SpeakableSpecification","xpath":["\/html\/head\/title","\/html\/head\/meta[@name='speakable-description']\/@content"]},"url":"https:\/\/www.rideapart.com\/news\/505612\/eeve-soul-electric-scooter-coming-soon\/"}    </script>

        <script type="application/ld+json">
        {"@context":"https:\/\/schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https:\/\/www.rideapart.com\/"},{"@type":"ListItem","position":2,"name":"News","item":"https:\/\/www.rideapart.com\/news\/"},{"@type":"ListItem","position":3,"name":"News","item":"https:\/\/www.rideapart.com\/news\/category\/news\/"}]}    </script>


    <div class="pre-center breadcrumbs-area ">
                <div slot="breadcrumbs" class="breadcrumbs">
        <a href="/">Home</a><span class="sep"></span><a href="/news/">News</a><span class="sep"></span><a href="/news/category/news/">News</a>    </div>
        <h1 class="m1-article-title">EeVe Soul Electric Scooter Expected To Debut Soon</h1>
    </div>
            <div class="pre-center">
            <div class="articleHeader">
                <div class="box-center">
                    <div class="originalImage scrollTieBox">
                        <picture>
                            <source type="image/webp" media="(min-width: 1921px)" srcset="https://cdn.motor1.com/images/mgl/XxEq9/s1/eeve-soul-electric-scooter-expected-to-debut-soon.webp">
                            <source type="image/jpeg" media="(min-width: 1921px)" srcset="https://cdn.motor1.com/images/mgl/XxEq9/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg">
                            <source type="image/webp" media="(min-width: 1024px) and (max-width: 1920px)" srcset="https://cdn.motor1.com/images/mgl/XxEq9/s3/eeve-soul-electric-scooter-expected-to-debut-soon.webp">
                            <source type="image/jpeg" media="(min-width: 1024px) and (max-width: 1920px)" srcset="https://cdn.motor1.com/images/mgl/XxEq9/s3/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 1x, https://cdn.motor1.com/images/mgl/XxEq9/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 2x, https://cdn.motor1.com/images/mgl/XxEq9/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 3x">
                            <source type="image/webp" media="(min-width: 414px) and (max-width: 1023px)" srcset="https://cdn.motor1.com/images/mgl/XxEq9/s4/eeve-soul-electric-scooter-expected-to-debut-soon.webp">
                            <source type="image/jpeg" media="(min-width: 414px) and (max-width: 1023px)" srcset="https://cdn.motor1.com/images/mgl/XxEq9/s4/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 1x, https://cdn.motor1.com/images/mgl/XxEq9/s2/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 2x, https://cdn.motor1.com/images/mgl/XxEq9/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 3x">
                            <source type="image/webp" media="(max-width: 413px)" srcset="https://cdn.motor1.com/images/mgl/XxEq9/s6/eeve-soul-electric-scooter-expected-to-debut-soon.webp">
                            <source type="image/jpeg" media="(max-width: 413px)" srcset="https://cdn.motor1.com/images/mgl/XxEq9/s6/eeve-soul-electric-scooter-expected-to-debut-soon.jpg, https://cdn.motor1.com/images/mgl/XxEq9/s4/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 2x, https://cdn.motor1.com/images/mgl/XxEq9/s3/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 3x">
                            <img src="https://cdn.motor1.com/images/mgl/XxEq9/s3/eeve-soul-electric-scooter-expected-to-debut-soon.jpg" alt="EeVe Soul Electric Scooter Expected To Debut Soon" />
                        </picture>
                    </div>
                </div>
                <div class="articleTitle">
                    <div class="box-center">
                        <div class="pre-center">
                                                    </div>
                    </div>
                </div>
            </div>
        </div>
    

<div class="pre-center padding  b-padding-skin pre-center-feature" id="post_box">
    <div data-bubbles="keyword" data-url="/news/store-keywords/" data-name="id"></div>
    <div class="content-area  " id="article_box" >
        <div class="content-area-box">
                            <div class="postTopInfo ">
                    <div class="postMeta-Top">
                                                        <div class="postDate"><span class="date" data-time="1620265632"><span class="date-data">May 06, 2021</span><span class="small"> at</span> 1:47am ET</span></div>                                                                            <div class="shareTrendingBox">
                                                                                                            <a href="/news/505612/eeve-soul-electric-scooter-coming-soon/#comments" class="commentsNumber disqus-comment-count" data-disqus-url="//hellforleather.disqus.com/count-data.json?url=https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/"></a>
                                                                                                                                    <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1620280723" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" class="share-button share-button-gallery"><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1620280723"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&text=EeVe+Soul+Electric+Scooter+Expected+To+Debut+Soon&via=RideApart"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&title=EeVe+Soul+Electric+Scooter+Expected+To+Debut+Soon&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&subject=EeVe%20Soul%20Electric%20Scooter%20Expected%20To%20Debut%20Soon"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                            </div>
                                            </div>


                        <div class="postAuthorBox withAvatar" xmlns="http://www.w3.org/1999/xhtml">
                    <div class="postAuthorThumb">
                <a class="userRThumb" href="/info/team/enrico-punsalang/">
                    <picture>
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/atr/2p1B/s4/enrico-punsalang.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/atr/2p1B/s4/enrico-punsalang.jpg">
                        <img src="https://cdn.motor1.com/images/atr/2p1B/s4/enrico-punsalang.jpg" alt="Enrico Punsalang" />
                    </picture>
                </a>
            </div>
                <div class="postAuthorInfo">
            <div class="postAuthor">
                <span class="name">
                    <span class="label">By</span>:
                                            <a class="author" content="Enrico Punsalang" href="/info/team/enrico-punsalang/">Enrico Punsalang</a>
                                    </span>
            </div>
                                            </div>
            </div>
                    <div class="clear"></div>

                </div>

            <div class="postContent content-wrapper">

                                    <h2 class="preview">
                        Another addition to the list of lightweight electric runabouts.                     </h2>
                                                <div class="postBody description e-content">
                                <p>The increase in popularity of lightweight, affordable <a href="https://www.rideapart.com/tag/electric-scooter/" data-inline-widget="internal-links" data-type-id="7" data-params="%7B%22tag%22%3A%22electric%20scooter%22%2C%22alias%22%3A%22electric-scooter%22%7D">electric scooter</a> all across the Asian market has made sustainable personal mobility more accessible to a greater number of commuters. With this increased demand, comes an influx of startups dedicated solely to developing and producing affordable electric scooters. As a result, consumers are now spoilt for choice in the rapidly growing electric two-wheeler market. </p><div class="apInarticleSmallRes"><div class="ap" data-place="25" style="width:300px;min-height:1px;" data-dfp-code="RA/ra_us/Rectangle" data-sizes="300x1,300x250" data-width="300" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"rectangle_first","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"first-inarticle-small-res"}'></div></div>
<p>Since variety is indeed the spice of life, <a href="https://www.rideapart.com/tag/india/" data-inline-widget="internal-links" data-type-id="7" data-params="%7B%22tag%22%3A%22Indian%22%2C%22originalTitle%22%3A%22india%22%2C%22alias%22%3A%22india%22%7D">Indian</a> electric two-wheeler startup EeVe, has announced that it will be launching a new electric scooter in the coming months. Dubbed the EeVe Soul, the company has secured approval for the development and production of the new scooter from the Automotive Research Association of India (ARAI). The Soul will be the Odisha-based company's first 'high-speed' model, meaning that it will be capable of a top speed of 70 kilometers per hour. Eeve also claims that the upcoming model will boast a range over 130 kilometers on a single charge.</p>
<section contenteditable="false" draggable="true" data-widget="image" data-border="" data-id="5811026" data-title=""><picture class="lazy"> <source srcset="https://cdn.motor1.com/custom/share/placeholder_0.jpg" type="image/webp" media="(min-width: 1025px)" data-srcset="https://cdn.motor1.com/images/mgl/pVnzv/s1/eeve-soul-electric-scooter-expected-to-debut-soon.webp" /> <source srcset="https://cdn.motor1.com/custom/share/placeholder_1.jpg" type="image/webp" data-srcset="https://cdn.motor1.com/images/mgl/pVnzv/s3/eeve-soul-electric-scooter-expected-to-debut-soon.webp 1x,
https://cdn.motor1.com/images/mgl/pVnzv/s2/eeve-soul-electric-scooter-expected-to-debut-soon.webp 2x" /> <source srcset="https://cdn.motor1.com/custom/share/placeholder_2.jpg" type="image/jpeg" media="(min-width: 1025px)" data-srcset="https://cdn.motor1.com/images/mgl/pVnzv/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg" /> <img draggable="false" src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="EeVe Soul Electric Scooter Expected To Debut Soon" data-srcset="https://cdn.motor1.com/images/mgl/pVnzv/s3/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 1x,
https://cdn.motor1.com/images/mgl/pVnzv/s1/eeve-soul-electric-scooter-expected-to-debut-soon.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/pVnzv/s3/eeve-soul-electric-scooter-expected-to-debut-soon.jpg" /> </picture></section>
<p>Should the EeVe Soul prove to be a success, the company hopes to produce even more high-speed electric two-wheelers in the coming years. In a report published by <em>The Bharat Express,</em> EeVe co-founder and director Harsh Didwania states, “We have received all approvals for the soul, as it will be called. ARAI has also approved it. But we have faced supply chain issues with the current second wave of the COVID- pandemic. 19. Once the system supplier and supply chain disruptions are resolved, we hope that by June or July 2021, we will be able to materialize the launch plans. The idea is to launch the Soul before Durga Puja and the end of year celebrations.”</p>
<p>EeVe is confident, that despite the ongoing second wave of COVID-19 infections, the company will be able to launch the new scooter before the festive season in June.  At present, EeVe India has four electric scooters on offer, and sees assembly in India, with parts sourced from OEMs all across the globe. That said, the company is targeting to achieve 100-percent local manufacturing of all its models. </p>
<section class="relatedContent-new" contenteditable="false" draggable="true" data-widget="related-content" data-widget-size="content" data-params="%7B%22type_id%22%3A0%2C%22title_id%22%3A%22%22%2C%22items%22%3A%5B%7B%22article_edition_id%22%3A%22505578%22%2C%22title%22%3A%22Indonesian%20Ride-Hailing%20App%20Gojek%20To%20Go%20All-Electric%20By%202030%22%2C%22alias%22%3A%22gojek-indonesian-app-going-electric-2030%22%2C%22section%22%3A%221%22%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2F8emvM%2Fs5%2Fgojek.jpg%22%7D%7D%2C%7B%22article_edition_id%22%3A%22505576%22%2C%22title%22%3A%22This%201919%20Harley-Davidson%20Is%20Now%20Rideable%20Thanks%20To%203D%20Printing%22%2C%22alias%22%3A%22harley-davidson-restored-3d-printing%22%2C%22section%22%3A%221%22%2C%22is_video%22%3A%220%22%2C%22images%22%3A%7B%22s5%22%3A%22https%3A%2F%2Fcdn.motor1.com%2Fimages%2Fmgl%2FOkE0R%2Fs5%2F1919-harley-davidson-with-3d-printed-distributor-cap.jpg%22%7D%7D%5D%7D"> <p class="trending-content_header">In Case You Missed It:</p> <div class="wrapper-related-item"> <div class="related-item"><a href="https://www.rideapart.com/news/505578/gojek-indonesian-app-going-electric-2030/"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="gojek indonesian app going electric 2030" data-srcset="https://cdn.motor1.com/images/mgl/8emvM/s6/gojek.jpg 1x,
https://cdn.motor1.com/images/mgl/8emvM/s4/gojek.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/8emvM/s6/gojek.jpg" /> </span> <span class="title-related-item">Indonesian Ride-Hailing App Gojek To Go All-Electric By 2030</span> </a></div> <div class="related-item"><a href="https://www.rideapart.com/news/505576/harley-davidson-restored-3d-printing/"> <span class="lazy related-item-img"> <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="harley davidson restored 3d printing" data-srcset="https://cdn.motor1.com/images/mgl/OkE0R/s6/1919-harley-davidson-with-3d-printed-distributor-cap.jpg 1x,
https://cdn.motor1.com/images/mgl/OkE0R/s4/1919-harley-davidson-with-3d-printed-distributor-cap.jpg 2x" data-src="https://cdn.motor1.com/images/mgl/OkE0R/s6/1919-harley-davidson-with-3d-printed-distributor-cap.jpg" /> </span> <span class="title-related-item">This 1919 Harley-Davidson Is Now Rideable Thanks To 3D Printing</span> </a></div> </div> </section>                </div>


                    
                        <div class="entityInfoBlock m-top">
                                                        <p class="source-link">
                                Sources:
                                
                                                                    <span class="item"><a class="source" target="_blank" href="https://www.drivespark.com/two-wheelers/2021/eeve-soul-electric-scooter-expected-to-launch-before-the-festive-season-read-more/articlecontent-pf138982-034072.html" rel="noopener nofollow">DriveSpark</a>,</span>                                                                    <span class="item"><a class="source" target="_blank" href="https://www.thebharatexpressnews.com/exclusive-eeve-soul-electric-scooter-launch-details-revealed/" rel="noopener nofollow">The Bharat Express</a></span>                                                            </p>
                        </div>
                    
                    <!-- new gallery place -->
                                        

                

                
                

                



                                

                                    <div class="parent-shareBox parent-shareBox-bottom">
                                                                                                            <a href="/news/505612/eeve-soul-electric-scooter-coming-soon/#comments" class="commentsNumber disqus-comment-count" data-disqus-url="//hellforleather.disqus.com/count-data.json?url=https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/"></a>
                                                                            <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1620280245" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" class="share-button share-button-gallery"><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1620280245"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&text=EeVe+Soul+Electric+Scooter+Expected+To+Debut+Soon&via=RideApart"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&title=EeVe+Soul+Electric+Scooter+Expected+To+Debut+Soon&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&subject=EeVe%20Soul%20Electric%20Scooter%20Expected%20To%20Debut%20Soon"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>                    </div>
                                            <div class="tip-us-email-container">
                            <div class="tip-us-email">
                                <span>Got a tip for us? Email:</span>
                                <a href="mailto: tips@rideapart.com">
                                    tips@rideapart.com                                </a>
                            </div>
                        </div>
                                        <div class="sapb social-banners"><div class="apb mleaderboard" style="padding:15px 0 15px 0;"><div class="ap" data-place="24" style="width:290px;min-height:1px;" data-dfp-code="RA/ra_us/Mobile_Leaderboard/Social" data-sizes="290x1,290x100" data-width="290" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"article_socials","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"article_socials"}'></div></div><div class="apb leaderboard" style="padding:15px 0 15px 0;"><div class="ap" data-place="23" style="width:650px;min-height:1px;" data-dfp-code="RA/ra_us/Leaderboard/Social" data-sizes="650x1,650x100" data-width="650" data-height="1" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"article_socials","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"article_socials"}'></div></div></div>                

                
                
                
                
                

                                

                
            </div>
        </div>






                    <div class="sidebar" id="post_sidebar">
                                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"dmpu_first","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"sidebar"}'></div></div>                                    
                                        <div class="trending-content">
        <div class="content-header">
            <p class="trending-content_header">Trending</p>
        </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/news/505344/michelin-plastic-bottles-sustainable-tires/">
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/7nX7q/s6/michelin-pilot-sport.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/7nX7q/s6/michelin-pilot-sport.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_0.jpg" alt="Michelin Will Turn Millions Of Plastic Bottles Into Tires" data-src="https://cdn.motor1.com/images/mgl/7nX7q/s6/michelin-pilot-sport.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/news/505344/michelin-plastic-bottles-sustainable-tires/">Michelin Will Turn Millions Of Plastic Bottles Into Tires</a>
            </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/news/505322/wsbk-philip-island-canceled-czech-round/">
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/7nXlV/s6/autodrom-most.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/7nXlV/s6/autodrom-most.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_1.jpg" alt="WSBK Cancels 2021 Philip Island Race And Adds Czech Round" data-src="https://cdn.motor1.com/images/mgl/7nXlV/s6/autodrom-most.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/news/505322/wsbk-philip-island-canceled-czech-round/">WSBK Cancels 2021 Philip Island Race And Adds Czech Round</a>
            </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/news/505345/indonesia-motorbikes-electric-vehicle-market/">
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/OkLbB/s6/treeletrik-scooters.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/OkLbB/s6/treeletrik-scooters.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_2.jpg" alt="Electric Bikes And Scooters To Pave Way For Indonesian EV Industry" data-src="https://cdn.motor1.com/images/mgl/OkLbB/s6/treeletrik-scooters.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/news/505345/indonesia-motorbikes-electric-vehicle-market/">Electric Bikes And Scooters To Pave Way For Indonesian EV Industry</a>
            </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/news/505116/bsa-b50-mx-for-sale/">
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/PO99X/s6/1973-bsa-b50-mx---left-side.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/PO99X/s6/1973-bsa-b50-mx---left-side.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_3.jpg" alt="This 1973 BSA B50 MX Will Probably Make Its New Owner Jump For Joy" data-src="https://cdn.motor1.com/images/mgl/PO99X/s6/1973-bsa-b50-mx---left-side.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/news/505116/bsa-b50-mx-for-sale/">This 1973 BSA B50 MX Will Probably Make Its New Owner Jump For Joy</a>
            </div>
                    
            <div class="trending-content_item">
                <a class="trending-content_thumb thumb zoom"  href="/news/505302/custom-royal-enfield-interceptor650-bobber/">
                                        <picture class="lazy">
                        <source type="image/webp" srcset="https://cdn.motor1.com/images/mgl/ljr8O/s6/this-royal-enfield-interceptor-has-been-transformed-into-a-gorgeous-bobber.webp">
                        <source type="image/jpeg" srcset="https://cdn.motor1.com/images/mgl/ljr8O/s6/this-royal-enfield-interceptor-has-been-transformed-into-a-gorgeous-bobber.jpg">
                        <img src="https://cdn.motor1.com/custom/share/placeholder_4.jpg" alt="This Custom Royal Enfield Interceptor Is A Gorgeous Bobber" data-src="https://cdn.motor1.com/images/mgl/ljr8O/s6/this-royal-enfield-interceptor-has-been-transformed-into-a-gorgeous-bobber.jpg" class="desaturate">                    </picture>
                </a>
                <a class="trending-content_link"  href="/news/505302/custom-royal-enfield-interceptor650-bobber/">This Custom Royal Enfield Interceptor Is A Gorgeous Bobber</a>
            </div>
            </div>

                
                                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"sidebar"}'></div></div>                            </div>
                <div class="clear"></div>
    </div>
</div>


<div id="container_3rd_party_service" class="container_3rd_party pre-center padding print-hide" data-edtn="ra_us">

            <div id="strossle-container">
        </div>
    
    
    
    
                <div class="sellwild-container">
    <div class="sellwild-wrapper" data-src="rideapart/rideapart-rideapart.js">
    </div>
</div>

    
    
        <div class="content-area">
        <div class="content-area-box">
                            <div id="comments" class="comment-container no-apb">
                                                                                            <div id="disqus_thread" class="diquas-wrapper" data-cid="article-505612" data-url="/news/505612/eeve-soul-electric-scooter-coming-soon/" data-title="EeVe Soul Electric Scooter Expected To Debut Soon">
                            </div>
                                                                                        <div class="comment-guidlines-link">
                            <a href="/articles/314646/rideapart-community-guidelines-and-standards/" target="_blank">Commenting Guidelines</a>
                        </div>
                                                                                <p class="text-uppercase bottom-heading">About this article</p>
                <table class="additionalInfo">
                                            <tr>
                            <td>Category</td>
                            <td><div class="list">
                                                                            <a href="/news/category/news/">News</a>
                                                                            <a href="/news/category/electric-motorcycles/">Electric Motorcycles</a>
                                                                    </div></td>
                        </tr>
                                                                                    <tr>
                            <td>Tags</td>
                            <td>
                                <div class="list">
                                                                            <a href="/tag/electric-scooter/">electric scooter</a>
                                                                    </div>
                            </td>
                        </tr>
                                                        </table>                                    </div>
                                    
                    </div>
        <div class="sidebar">
                            <div class="mobile-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"sidebar"}'></div></div>                </div>
                <div class="lazy-load-adv">
                    <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"sidebar"}'></div></div>                </div>
                                </div>
        <div class="clear"></div>

    </div>


    


    
                </div>

<div class="pre-center mobile-skyscraper-box">
            <div class="apb apb-dmpu"><div class="ap" data-place="4" style="width:300px;min-height:250px;" data-dfp-code="RA/ra_us/DMPU" data-sizes="300x250,300x600" data-width="300" data-height="250" data-dfp-attrs='{"lazy":1,"msnt_env":"production","m1_banner_place":"dmpu","m1_edition":"ra_us","m1_article_type":"news","m1_page_content_id":505612,"m1_page_type":"detail","m1_page_content_type":"article","m1_categories":["news","electric-motorcycles"],"m1_tags":["electric scooter"],"m1_banner_position":"sidebar"}'></div></div>    
</div>

<div class="cpre-center print-hide">
    </div>

    <div id="stop_share_box" class="print-hide"></div>

                


        </div>


<div class="m1-left-side">
    <div class="m1-drawer left-to-right disabled" data-button-target="mainMenu">
        <div onclick="" data-button data-id="mainMenuToggle" data-close-delay="0.5" data-value="mainMenu" data-hide-scroll="m1-left-side-box" data-clear="2" class="m1-drawer-close-button dark active" data-toggle="1" data-multi></div>
        <div class="m1-left-side-top">
            <div class="m1-user-side-label">
                <span class="label flex-parent two-line">
                   <a class="login" href="/connect/msnt/">Sign In</a>
                   <span class="hide_mobile">or</span>
                   <a class="register" href="/connect/msnt/?is_registration=1">Sign Up</a>
                </span>
                <span class="hide_mobile userpic icon-user"></span>
            </div>
        </div>
        <div class="m1-left-side-box">
                        <ul class="m1-navigation-main print-hide">
                                <li class="m1-navigation-main__animated-block grand top left mobile">
            <a href="/news/" >
                                    News                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block grand top left mobile">
            <a href="/reviews/" >
                                    Reviews                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block grand top left mobile">
            <a href="/features/" >
                                    Features                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block top">
            <a href="/motorcycle-lists/" >
                                    Lists                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block grand left">
            <a href="/motorcycle-lists/" >
                                    Motorcycle Lists                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a href="/features/category/how-to/" >
                                    How To                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a href="/reviews/category/gear/" >
                                    Gear                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a href="/news/category/rideapart-women/" >
                                    RideApart Women                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a href="/news/category/racing/" >
                                    Racing                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a href="/features/category/motorcycle-history/" >
                                    history                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block left">
            <a href="/makes/" >
                                    makes &amp; models                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block photos ico left">
            <a href="/photos/" >
                                    Photos                                
            </a>
        </li>
                            <li class="m1-navigation-main__animated-block videos ico left">
            <a href="/videos/" >
                                    Videos                                
            </a>
        </li>
    </ul>
            <div class="m1-menus-box">
                <div class="m1-navigation-main__animated-block m1-extra-menus-box">
                    <a href="/" class="m1-side-logo"></a>
                    
                                            <ul class="m1-social-menu">
                                                                                <li class="facebook"><a class="icon-facebook-redirect-link" href="https://www.facebook.com/RideApart" target="_blank"></a></li>
                                                                                                                                                                <li class="twitter"><a class="icon-twitter-redirect-link" href="https://twitter.com/RideApart" target="_blank"></a></li>
                                                                                                                                                                                                                                                                                                                            <li class="gnews"><a class="icon-gnews-redirect-link" href="https://news.google.com/publications/CAAqBwgKMJ_0_QowtZr2Ag" target="_blank"></a></li>
                                                                                                                                                                                                                                                                        <li class="instagram"><a class="icon-instagram-redirect-link" href="https://www.instagram.com/RideApart/" target="_blank"></a></li>
                                                                                                                                                                                                                                                                        <li class="rss"><a class="icon-rss-redirect-link" href="/rss/" ></a></li>
                                                                            </ul>
                    
                    <ul class="m1-info-menu">
                        <li><a href="/info/about-us/">About Us</a></li>
                                                    <li><a href="https://newsletter.rideapart.com/signup/" target="_blank">Newsletter</a></li>
                                                <li><a href="/info/advertising/">Advertising</a></li>
                        <li><a href="/info/feedback/tip-us/">Tip us</a></li>
                        <li><a href="/info/contact/">Contact</a></li>
                                                                                <li><a href="https://info.wrightsmedia.com/rideapart-licensing-permissions" target="_blank">LICENSING</a></li>
                                                                            <li class="one-trust">
                                <!-- OneTrust Cookies Settings button start -->
                                <button id="ot-sdk-btn" class="ot-sdk-show-settings">Cookie Settings</button>
                                <!-- OneTrust Cookies Settings button end -->
                            </li>
                                                <li><a href="/info/cookie-policy/">Cookie policy</a></li>
                        <li><a href="https://accounts.motorsportnetwork.com/legal/privacy-policy" target="_blank">Privacy policy</a></li>
                    </ul>

                </div>
                <div class="m1-navigation-main__animated-block m1-msn-menus-box">
                    <ul class="m1-msn-menu">                        
                        <li><a href="https://www.motorsport.com/" target="_blank">Motorsport.com</a></li>
                        <li><a href="https://motorsport.tv/" target="_blank">Motorsport.tv</a></li>
                                                    <li><a href="https://www.motor1.com" target="_blank">Motor1.com</a></li>
                                                                            <li><a href="https://insideevs.com" target="_blank">Insideevs.com</a></li>
                                                                            <li><a href="https://www.autoclassics.com/" target="_blank">Autoclassics.com</a></li>
                                                                        
                        <li><a href="https://www.myev.com/" target="_blank">Myev.com</a></li>
                    </ul>
                </div>
                <div class="m1-navigation-main__animated-block m1-footer">
                    &copy; 2021 <a target="_blank" class="m1-msn-name" href="https://www.motorsportnetwork.com/company/about">Motorsport Network.</a>                                                         </div>
                            </div>
        </div>
    </div>
    <div class="m1-drawer-overlay"></div>
</div>

<m1-check-availability-response-dialog
        user-data='{"email":"","zip":"","phone":"","firstName":"","lastName":""}'
        edition="ra_us"
        oem-url="/buy/new/lead/"
        vin-url="/buy/used/lead/"
></m1-check-availability-response-dialog>


    <div id="share_box_content_wrapper">
        <div slot="share-box" class="big-shareBox shareBox share-box-dropdown to-down"><div class="share-box-wrapper"><span class="shareBox-separator" data-value="share-list-1620280974" data-button onClick="" data-id="toggleBox" data-static> <span class="active"><span class="icon-plus">+</span></span><span class="passive"><span class="icon-plus">+</span></span></span><a href="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" class="share-button share-button-gallery"><span class="icon share-empty"></span></a><div class="share-list" data-button-target="share-list-1620280974"><ul><li class="facebook"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="1" data-share-network="Facebook" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon facebook"></span><span class="name">Share on Facebook</span></a></li><li class="twitter"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="2" data-share-network="Twitter" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="450" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&text=EeVe+Soul+Electric+Scooter+Expected+To+Debut+Soon&via=RideApart"><span class="social-bg icon twitter"></span><span class="name">Share on Twitter</span></a></li><li class="linkedin"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="3" data-share-network="LinkedIn" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://www.linkedin.com/cws/share?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon linkedin"></span><span class="name">Share on LinkedIn</span></a></li><li class="flipboard"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="7" data-share-network="Flipboard" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://share.flipboard.com/bookmarklet/popout?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&title=EeVe+Soul+Electric+Scooter+Expected+To+Debut+Soon&v=2"><span class="social-bg icon flipboard"></span><span class="name">Share on Flipboard</span></a></li><li class="reddit"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="6" data-share-network="Reddit" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="900" data-height="600" href="https://www.reddit.com/submit?url=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon reddit"></span><span class="name">Share on Reddit</span></a></li><li class="whatsapp"><a data-button="" data-id="share" data-url="/connect/share/" data-name="network_id" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-value="6" data-share-network="WhatsApp" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="600" href="https://api.whatsapp.com/send?text=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F"><span class="social-bg icon whatsapp"></span><span class="name">Share on WhatsApp</span></a></li><li class="mailto"><a data-button="" data-id="mailTo" target="_blank" data-extra-params="id:'505612',type_id:'1'" data-share-url="https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/" data-width="600" data-height="400" href="mailto:?body=https%3A%2F%2Fwww.rideapart.com%2Fnews%2F505612%2Feeve-soul-electric-scooter-coming-soon%2F&subject=EeVe%20Soul%20Electric%20Scooter%20Expected%20To%20Debut%20Soon"><span class="social-bg icon mailto"></span><span class="name">Send to email</span></a></li></ul></div></div></div>    </div>


<!--<div class="adminInfoBoxx"></div>-->

<div class="m1-footer-messages"></div>

<script>
     window.gadsId = false;
</script>
<script>
    var m1FooterMessages = [];
    // m1FooterMessages.push({
    //     message: "This website uses cookies to ensure you get the best experience on our website. By closing this banner, scrolling this page you consent to the use of cookies. <a id='cookie_accept_link' data-id='footerMessageAccept' data-button='' href='/info/cookie-policy/'>More info.</a>",
    //     name: "cookie_accept"
    // });
    </script>

<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/build/jslangs/rideapart_en_US_555a609a617b1448cc0acdb0c1d8166c.js"></script>
<script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/js/0_3264efce3f4dba7c6f91.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/js/2_3264efce3f4dba7c6f91.js"></script><script defer type="text/javascript" src="https://cdn.motor1.com/kp/static4ui/prod_v2_eks_222/design/dist/js/11_3264efce3f4dba7c6f91.js"></script>

        <script async src="https://console.adgrid.io/adgrid-build/ad-grid-rideapart-com.js"></script>

    
<script>
gtmDataLayer = [{
    'currentEdition': 'ra_us',
    'currentEnv': 'production',
        'pageType': 'detail',
            'entityType': 'article',
                    'pageId': 'index_articles_detail',
            'entityAuthors': ["Enrico Punsalang"],
            'pageUrl': 'https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/',
            'pageUrlCanonical': 'https://www.rideapart.com/news/505612/eeve-soul-electric-scooter-coming-soon/',
            'pageLanguage': 'en',
            'entityCategories': ["News","Electric Motorcycles"],
            'articleType': 'news',
                    'entityTitle': 'EeVe Soul Electric Scooter Expected To Debut Soon',
            'pageTitle': 'EeVe Soul Electric Scooter Expected To Debut Soon',
            'm1DataSign': 'f4cff8e2a2f21c9bed53d3a57ba91cc9',
            'articleId': '505612',
            'tags': ["electric scooter"],
                'sessionId': '16613a40b70d3b08bc19fb84d0bada80',
    'msntClientId': '92'
}];
</script>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer','GTM-TJCLXGW');</script>

<script>
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','gtmDataLayer', 'GTM-TCCR6TV');
</script>




<!-- <script>
    window.onload = function() {

        if ((typeof $.cookie('PHPSESSID') === 'undefined') || (typeof $.cookie('is_logged_in') !== 'undefined')){
            $.get('/layout-auth-data/', function(data) {
                $('.m1-user-side-label').html(data);

                var loginButton = document.getElementsByClassName('login')[0];
                var registerButton = document.getElementsByClassName('register')[0];

                if (msnt) {
                    if (loginButton) {
                        loginButton.addEventListener('click', function(event){
                            event.preventDefault();
                            event.stopPropagation();
                            window.msnt.register = false;
                            msnt.openIframeWindow();
                        });
                    }
                    if (registerButton) {
                        registerButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = true;
                        msnt.openIframeWindow();
                        });
                    }
                }
            });

            var loginButton = document.getElementsByClassName('login')[0];
            var registerButton = document.getElementsByClassName('register')[0];

            if (msnt) {
                if (loginButton) {
                    loginButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = false;
                        msnt.openIframeWindow();
                    });
                }

                if (registerButton) {
                    registerButton.addEventListener('click', function(event){
                        event.preventDefault();
                        event.stopPropagation();
                        window.msnt.register = true;
                        msnt.openIframeWindow();
                    });
                }
            }
        }
    }

</script> -->
</body>
</html>
